Name:ProTrader
 
Version:1.6.6.2
 
Publisher:PT. Phillip Securities Indonesia
 
The following prerequisites are required:
 
  • .NET Framework 2.0
If these components are already installed, you can launch the application now. Otherwise, click the button below to install the prerequisites and run the application.
 
Note : To Install POEMS ProTrader, you have to use Internet Explorer ver 7.0 or above.
Install
 
PT. Phillip Securities Indonesia Customer Support    ::    ClickOnce and .NET Framework Resources